]> git.pld-linux.org Git - packages/perl-Parse-RPM-Spec.git/blob - perl-Parse-RPM-Spec.spec
package Parse/RPM dir
[packages/perl-Parse-RPM-Spec.git] / perl-Parse-RPM-Spec.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Parse
6 %define         pnam    RPM-Spec
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Parse::RPM::Spec - Perl extension to parse RPM spec files
9 Name:           perl-Parse-RPM-Spec
10 Version:        0.08
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Parse/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  247aadd8017bbd5f058e79fe3d43302c
17 URL:            http://search.cpan.org/dist/Parse-RPM-Spec/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Moose)
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 RPM is the package management system used on Linux distributions based
29 on Red Hat Linux. These days that includes Fedora, Red Hat Enterprise
30 Linux, Centos, SUSE, Mandriva and many more.
31
32 RPMs are build from the source of a packages along with a spec file.
33 The spec file controls how the RPM is built.
34
35 This module creates Perl objects which module spec files. Currently it
36 gives you simple access to various pieces of information from the spec
37 file.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Build.PL \
44         destdir=$RPM_BUILD_ROOT \
45         installdirs=vendor
46 ./Build
47
48 %{?with_tests:./Build test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 ./Build install
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %dir %{perl_vendorlib}/Parse/RPM
62 %{perl_vendorlib}/Parse/RPM/Spec.pm
63 %{_mandir}/man3/Parse::RPM::Spec.3pm*
This page took 0.110744 seconds and 3 git commands to generate.