]> git.pld-linux.org Git - packages/perl-Parse-CPAN-Meta.git/blob - perl-Parse-CPAN-Meta.spec
be6f75fd55a86279c65a8e33ae951be5bc9877f6
[packages/perl-Parse-CPAN-Meta.git] / perl-Parse-CPAN-Meta.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Parse
6 %define pnam    CPAN-Meta
7 Summary:        Parse::CPAN::Meta - parse META.yml and other similar CPAN metadata files
8 Summary(pl.UTF-8):      Parse::CPAN::Meta - analiza META.yml i innych podobnych plików z metadanymi CPAN
9 Name:           perl-Parse-CPAN-Meta
10 Version:        1.4422
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Parse/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  71d52f680b19b3ef36e9a0152e8a3e93
16 URL:            http://search.cpan.org/dist/Parse-CPAN-Meta/
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(File::Spec) >= 0.80
22 BuildRequires:  perl-CPAN-Meta-YAML >= 0.011
23 BuildRequires:  perl-JSON-PP >= 2.27300
24 BuildRequires:  perl-Test-Simple >= 0.47
25 %endif
26 Requires:       perl-CPAN-Meta-YAML >= 0.011
27 Requires:       perl-JSON-PP >= 2.27300
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Parse::CPAN::Meta is a parser for META.yml files, based on the parser
33 half of YAML::Tiny.
34
35 It supports a basic subset of the full YAML specification, enough to
36 implement parsing of typical META.yml files, and other similarly
37 simple YAML files.
38
39 If you need something with more power, move up to a full YAML parser
40 such as YAML, YAML::Syck or YAML::LibYAML.
41
42 %description -l pl.UTF-8
43 Parse::CPAN::Meta jest analizatorem plików META.yml opartym na części
44 analizującej modułu YAML::Tiny.
45
46 Obsługuje podstawowy podzbiór pełnej specyfikacji YAML, wystarczający
47 do analizy typowych plików META.yml i innych podobnie prostych plików
48 YAML.
49
50 Jeżeli potrzebne jest coś o większych możliwościach, należy użyć
51 pełnego analizatora YAML-a - np. z modułu YAML, YAML::Syck lub
52 YAML::LibYAML.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes
76 %dir %{perl_vendorlib}/Parse/CPAN
77 %{perl_vendorlib}/Parse/CPAN/Meta.pm
78 %{_mandir}/man3/Parse::CPAN::Meta.3pm*
This page took 0.045689 seconds and 2 git commands to generate.