]> git.pld-linux.org Git - packages/perl-Parse-CPAN-Meta.git/blob - perl-Parse-CPAN-Meta.spec
672cd027b8ca1a64320c2d17214b8338b5d5a716
[packages/perl-Parse-CPAN-Meta.git] / perl-Parse-CPAN-Meta.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Parse
7 %define pnam    CPAN-Meta
8 Summary:        Parse::CPAN::Meta - parse META.yml and other similar CPAN metadata files
9 Summary(pl.UTF-8):      Parse::CPAN::Meta - analiza META.yml i innych podobnych plików z metadanymi CPAN
10 Name:           perl-Parse-CPAN-Meta
11 Version:        1.4402
12 Release:        1
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Parse/DAGOLDEN/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  136571ea3aa3b21046346f7d1606a0a6
17 URL:            http://search.cpan.org/dist/Parse-CPAN-Meta/
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(File::Spec) >= 0.80
23 BuildRequires:  perl-CPAN-Meta-YAML >= 0.002
24 BuildRequires:  perl-JSON-PP >= 2.27103
25 BuildRequires:  perl-Test-Simple >= 0.47
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Parse::CPAN::Meta is a parser for META.yml files, based on the parser
32 half of YAML::Tiny.
33
34 It supports a basic subset of the full YAML specification, enough to
35 implement parsing of typical META.yml files, and other similarly
36 simple YAML files.
37
38 If you need something with more power, move up to a full YAML parser
39 such as YAML, YAML::Syck or YAML::LibYAML.
40
41 %description -l pl.UTF-8
42 Parse::CPAN::Meta jest analizatorem plików META.yml opartym na części
43 analizującej modułu YAML::Tiny.
44
45 Obsługuje podstawowy podzbiór pełnej specyfikacji YAML, wystarczający
46 do analizy typowych plików META.yml i innych podobnie prostych plików
47 YAML.
48
49 Jeżeli potrzebne jest coś o większych możliwościach, należy użyć
50 pełnego analizatora YAML-a - np. z modułu YAML, YAML::Syck lub
51 YAML::LibYAML.
52
53 %prep
54 %setup -q -n %{pdir}-%{pnam}-%{version}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} pure_install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes
75 %dir %{perl_vendorlib}/Parse/CPAN
76 %{perl_vendorlib}/Parse/CPAN/Meta.pm
77 %{_mandir}/man3/Parse::CPAN::Meta.3pm*
This page took 0.064199 seconds and 2 git commands to generate.