]> git.pld-linux.org Git - packages/perl-Params-Classify.git/blob - perl-Params-Classify.spec
d4af03dafa7c12b86c5fe74d32958bcfd98b1c90
[packages/perl-Params-Classify.git] / perl-Params-Classify.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Params
6 %define         pnam    Classify
7 Summary:        Params::Classify - argument type classification
8 Summary(pl.UTF-8):      Params::Classify - klasyfikacja typu argumentu
9 Name:           perl-Params-Classify
10 Version:        0.015
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Params/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3c3367d759ed5bd6fe86c1f35e9b51ed
17 URL:            http://search.cpan.org/dist/Params-Classify/
18 BuildRequires:  perl-ExtUtils-ParseXS >= 2.2006
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Scalar-List-Utils >= 1.01
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides various type-testing functions. These are
29 intended for functions that, unlike most Perl code, care what type of
30 data they are operating on. For example, some functions wish to
31 behave differently depending on the type of their arguments (like
32 overloaded functions in C++).
33
34 %description -l pl.UTF-8
35 Ten moduł udostępnia różne funkcje do sprawdzania typów. Mają być
36 przydatne dla funkcji, które - w przeciwieństwie do większości kodu
37 perlowego - zwracają uwagę na typ danych, na których operują; np.
38 dla funkcji, które zachowują się różnie w zależności od typu
39 argumentów (jak przeciążone funkcje w C++).
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Build.PL \
46         installdirs=vendor \
47         --config cc="%{__cc}" \
48         --config ld="%{__cc}" \
49         --config optimize="%{rpmcflags}"
50
51 ./Build
52
53 %{?with_tests:./Build test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 ./Build install \
59         destdir=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorarch}/Params/Classify.pm
68 %dir %{perl_vendorarch}/auto/Params/Classify
69 %attr(755,root,root) %{perl_vendorarch}/auto/Params/Classify/Classify.so
70 %{_mandir}/man3/Params::Classify.3pm*
This page took 0.080798 seconds and 2 git commands to generate.