]> git.pld-linux.org Git - packages/perl-Params-Classify.git/blob - perl-Params-Classify.spec
33a9d9724d492f3954e1dc13e354ea6f46764ed5
[packages/perl-Params-Classify.git] / perl-Params-Classify.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Params
6 %define         pnam    Classify
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Params::Classify - argument type classification
9 Summary(pl.UTF-8):      Params::Classify - klasyfikacja typu argumentu
10 Name:           perl-Params-Classify
11 Version:        0.013
12 Release:        10
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Params/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  63d24fbec775472ada49d16bce4a9b1f
18 Patch0:         op_sibling_fixes.patch
19 URL:            http://search.cpan.org/dist/Params-Classify/
20 BuildRequires:  perl-ExtUtils-ParseXS >= 2.2006
21 BuildRequires:  perl-Module-Build
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with tests}
25 BuildRequires:  perl-Scalar-List-Utils >= 1.01
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module provides various type-testing functions. These are
31 intended for functions that, unlike most Perl code, care what type of
32 data they are operating on. For example, some functions wish to
33 behave differently depending on the type of their arguments (like
34 overloaded functions in C++).
35
36 %description -l pl.UTF-8
37 Ten moduł udostępnia różne funkcje do sprawdzania typów. Mają być
38 przydatne dla funkcji, które - w przeciwieństwie do większości kodu
39 perlowego - zwracają uwagę na typ danych, na których operują; np.
40 dla funkcji, które zachowują się różnie w zależności od typu
41 argumentów (jak przeciążone funkcje w C++).
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45 %patch0 -p1
46
47 %build
48 %{__perl} Build.PL \
49         installdirs=vendor \
50         --config cc="%{__cc}" \
51         --config ld="%{__cc}" \
52         --config optimize="%{rpmcflags}"
53
54 ./Build
55
56 %{?with_tests:./Build test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 ./Build install \
62         destdir=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorarch}/Params/Classify.pm
71 %dir %{perl_vendorarch}/auto/Params/Classify
72 %attr(755,root,root) %{perl_vendorarch}/auto/Params/Classify/Classify.so
73 %{_mandir}/man3/Params::Classify.3pm*
This page took 0.084768 seconds and 2 git commands to generate.