]> git.pld-linux.org Git - packages/perl-Parallel-Prefork.git/blob - perl-Parallel-Prefork.spec
- up to 0.18
[packages/perl-Parallel-Prefork.git] / perl-Parallel-Prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Parallel
6 %define         pnam    Prefork
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Parallel::Prefork - A simple prefork server framework
9 Name:           perl-Parallel-Prefork
10 Version:        0.18
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Parallel/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  128f8c03eddde44d3e95f092d6116e9a
17 URL:            http://search.cpan.org/dist/Parallel-Prefork/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::Accessor::Lite) >= 0.04
22 BuildRequires:  perl(Proc::Wait3) >= 0.03
23 BuildRequires:  perl(Scope::Guard)
24 BuildRequires:  perl-List-MoreUtils
25 BuildRequires:  perl-Test-Requires
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Parallel::Prefork is much like Parallel::ForkManager, but supports
32 graceful shutdown and run-time reconfiguration.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Parallel/*.pm
57 %{perl_vendorlib}/Parallel/Prefork
58 %{_mandir}/man3/*
This page took 0.051777 seconds and 3 git commands to generate.