]> git.pld-linux.org Git - packages/perl-PadWalker.git/blob - perl-PadWalker.spec
- fixed perl-devel BR
[packages/perl-PadWalker.git] / perl-PadWalker.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    PadWalker
7 Summary:        PadWalker - play with other peoples' lexical variables
8 Summary(pl):    PadWalker - igranie z cudzymi zmiennymi leksykalnymi
9 Name:           perl-PadWalker
10 Version:        0.10
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/R/RO/ROBIN/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  e6f48685932c1a1896872daf1aff9e3d
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PadWalker is a Perl module which allows you to inspect (and even
23 change!) lexical variables in any subroutine which called you. It will
24 only show those variables which are in scope at the point of the call.
25
26 %description -l pl
27 PadWalker jest modu³em Perla umo¿liwiaj±cym przegl±danie (a nawet
28 modyfikacje!) zmiennych leksykalnych w dowolnej wywo³anej funkcji.
29 Pokazuje on tylko te zmienne, których zasiêg obejmuje miejsce
30 wywo³ania.
31
32 %prep
33 %setup -q -n %{pdir}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorarch}/*.pm
56 %dir %{perl_vendorarch}/auto/%{pdir}
57 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
58 %{perl_vendorarch}/auto/%{pdir}/*.bs
59 %{_mandir}/man3/*
This page took 0.053077 seconds and 4 git commands to generate.