]> git.pld-linux.org Git - packages/perl-PadWalker.git/blob - perl-PadWalker.spec
- new
[packages/perl-PadWalker.git] / perl-PadWalker.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    PadWalker
7 Summary:        PadWalker - play with other peoples' lexical variables
8 #Summary(pl):   
9 Name:           perl-PadWalker
10 Version:        0.10
11 Release:        1
12 # same as perl
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/J/JU/JUERD/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  e6f48685932c1a1896872daf1aff9e3d
17 BuildRequires:  perl-devel >= 5.6
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PadWalker is a module which allows you to inspect (and even change!)
23 lexical variables in any subroutine which called you. It will only show
24 those variables which are in scope at the point of the call.
25
26 # %description -l pl
27 # TODO
28
29 %prep
30 %setup -q -n %{pdir}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make} OPTIMIZE="%{rpmcflags}"
36
37 %{!?_without_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes README
51 %{perl_vendorarch}/*.pm
52 %dir %{perl_vendorarch}/auto/%{pdir}
53 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/*.so
54 %{perl_vendorarch}/auto/%{pdir}/*.bs
55 %{_mandir}/man3/*
This page took 0.081197 seconds and 4 git commands to generate.