]> git.pld-linux.org Git - packages/perl-PadWalker.git/blob - perl-PadWalker.spec
rebuild with perl 5.32
[packages/perl-PadWalker.git] / perl-PadWalker.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %define         pdir    PadWalker
6 Summary:        PadWalker - play with other peoples' lexical variables
7 Summary(pl.UTF-8):      PadWalker - igranie z cudzymi zmiennymi leksykalnymi
8 Name:           perl-PadWalker
9 Version:        2.3
10 Release:        3
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/R/RO/ROBIN/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  361ba6079224d6710a2e2c4131875f0b
16 URL:            http://search.cpan.org/dist/PadWalker/
17 BuildRequires:  perl-devel >= 1:5.8.1
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PadWalker is a Perl module which allows you to inspect (and even
23 change!) lexical variables in any subroutine which called you. It will
24 only show those variables which are in scope at the point of the call.
25
26 %description -l pl.UTF-8
27 PadWalker jest modułem Perla umożliwiającym przeglądanie (a nawet
28 modyfikacje!) zmiennych leksykalnych w dowolnej wywołanej funkcji.
29 Pokazuje on tylko te zmienne, których zasięg obejmuje miejsce
30 wywołania.
31
32 %prep
33 %setup -q -n %{pdir}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorarch}/PadWalker.pm
57 %dir %{perl_vendorarch}/auto/PadWalker
58 %attr(755,root,root) %{perl_vendorarch}/auto/PadWalker/PadWalker.so
59 %{_mandir}/man3/PadWalker.3pm*
This page took 0.035859 seconds and 3 git commands to generate.