]> git.pld-linux.org Git - packages/perl-Package-Stash.git/blob - perl-Package-Stash.spec
- up to 0.38
[packages/perl-Package-Stash.git] / perl-Package-Stash.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Package
6 %define         pnam    Stash
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Package::Stash - routines for manipulating stashes
9 Summary(pl.UTF-8):      Package::Stash - funkcje do manipulowania tablicami symboli
10 Name:           perl-Package-Stash
11 Version:        0.38
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Package/Package-Stash-%{version}.tar.gz
17 # Source0-md5:  dc2d802eea2cb0b52ed9c4dd178761dd
18 URL:            http://search.cpan.org/dist/Package-Stash/
19 BuildRequires:  perl-Dist-CheckConflicts >= 0.02
20 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
21 BuildRequires:  perl-devel >= 1:5.8.1
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Module-Implementation >= 0.06
25 BuildRequires:  perl-Package-Stash-XS >= 0.26
26 BuildRequires:  perl-Package-DeprecationManager
27 BuildRequires:  perl-Test-Fatal
28 BuildRequires:  perl-Test-Requires
29 BuildRequires:  perl-Test-Simple >= 0.88
30 %endif
31 Suggests:       perl-Package-Stash-XS >= 0.26
32 Conflicts:      perl-Class-MOP <= 1.08
33 Conflicts:      perl-MooseX-Method-Signatures <= 0.36
34 Conflicts:      perl-MooseX-Role-WithOverloading <= 0.08
35 Conflicts:      perl-namespace-clean <= 0.18
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Manipulating stashes (Perl's symbol tables) is occasionally necessary,
41 but incredibly messy, and easy to get wrong. This module hides all of
42 that behind a simple API.
43
44 %description -l pl.UTF-8
45 Manipulowanie stashami (perlowymi tablicami symboli) jest czasem
46 niezbędne, ale bardzo zawiłe i błędogenne. Ten moduł ukrywa wszystko w
47 prostym API.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 # already handled by rpm Conflicts - don't generate Dist::CheckConflicts dep
66 %{__rm} $RPM_BUILD_ROOT%{_bindir}/package-stash-conflicts \
67         $RPM_BUILD_ROOT%{perl_vendorlib}/Package/Stash/Conflicts.pm \
68         $RPM_BUILD_ROOT%{_mandir}/man1/package-stash-conflicts.1p
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorlib}/Package/Stash.pm
77 %{perl_vendorlib}/Package/Stash
78 %{_mandir}/man3/Package::Stash*.3pm*
This page took 0.061393 seconds and 3 git commands to generate.