]> git.pld-linux.org Git - packages/perl-PXR.git/blob - perl-PXR.spec
49de595e3584d3651995a788d03795443cee8670
[packages/perl-PXR.git] / perl-PXR.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    PXR
7 Summary:        PXR - Perl XML router tools for use in other projects
8 Summary(pl.UTF-8):      PXR - narzędzia routera XML w Perlu do wykorzystania w innych projektach
9 Name:           perl-PXR
10 Version:        0.1.5
11 Release:        2
12 # package have GPLv2 attached in Source0
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/N/NP/NPEREZ/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  ee51da0051dc83824b69eddab013f1d8
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-POE-Filter-XML
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Perl XML Router tools that contains:
27 - PXR::Node     - provides an slick, featureful XML node representation;
28 - PXR::Parser   - a simple, speedy, efficient pure Perl SAX XML parser;
29 - PXR::NS       - namespace constants for PXR/JABBER(tm)/XMPP
30                   development;
31 - PXR::Utils    - general purpose common utility functions for PXR
32                   Tools.
33
34 %description -l pl.UTF-8
35 Narzędzia routera XML w Perlu, zawierające:
36 - PXR::Node     - udostępnia zgrabną, posiadającą duże możliwości
37                   reprezentację węzłów XML;
38 - PXR::Parser   - prosty, szybki, wydajny analizator SAX XML w czystym
39                   Perlu;
40 - PXR::NS       - stałe przestrzeni nazw dla tworzenia programów
41                   korzystających z PXR/JABBER(tm)/XMPP;
42 - PXR::Utils    - funkcje narzędziowe ogólnego stosowania dla PXR Tools.
43
44 %prep
45 %setup -q -n %{pdir}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %{perl_vendorlib}/*.pm
66 %{perl_vendorlib}/%{pdir}
67 %{_mandir}/man3/*
This page took 0.069195 seconds and 2 git commands to generate.