]> git.pld-linux.org Git - packages/perl-POE.git/blob - perl-POE.spec
- up to 1.367
[packages/perl-POE.git] / perl-POE.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 Summary:        POE - multitasking and networking framework for Perl
8 Summary(pl.UTF-8):      POE - wielozadaniowe i sieciowe środowisko dla Perla
9 Name:           perl-POE
10 Version:        1.367
11 Release:        1
12 Epoch:          2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  9b2e4375152b139e4ab5f7dfb2cc5b15
18 URL:            http://poe.perl.org/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  perl-Test-Simple >= 0.54
22 %if %{with tests}
23 BuildRequires:  perl(Filter::Util::Call) >= 1.04
24 BuildRequires:  perl-IO-Compress
25 BuildRequires:  perl-Curses
26 BuildRequires:  perl-Event
27 BuildRequires:  perl-IO-Tty >= 1.08
28 BuildRequires:  perl-Socket6 >= 0.14
29 BuildRequires:  perl-Storable >= 2.12
30 BuildRequires:  perl-Term-ReadKey >= 2.21
31 BuildRequires:  perl-Time-HiRes >= 1.59
32 BuildRequires:  perl-URI >= 1.30
33 BuildRequires:  perl-libwww
34 %endif
35 Conflicts:      perl-POE-Filter-XML < 0.29
36 Obsoletes:      perl-POE-Exceptions
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define _noautoreq      perl(Curses) perl(HTTP::Date) perl(HTTP::Request) perl(HTTP::Response) perl(HTTP::Status) perl(URI) perl(Term::Cap) perl(Term::ReadKey) perl(Tk)
41
42 %description
43 POE is an acronym of "Perl Object Environment".  It's a networking
44 and multitasking (some say cooperative threading) framework for Perl.
45 It has been in active development since 1996, with its first open
46 release in 1998.  O'Reilly's Perl Conference (now OSCON) named POE
47 "Best New Module" in 1999.
48
49 POE has been used in mission-critical systems such as internetworked
50 financial markets, file systems, commerce and application servers.
51 It has been used in projects ranging from a few lines of code to tens
52 of thousands.
53
54 POE is compatible with perl versions as old as 5.005_03.
55
56 POE includes an evolving component framework.  Components are high-level,
57 modular, reusable pieces of programs.  Several components have been
58 published on the CPAN, and more are listed on POE's web site.
59
60 POE includes components and libraries for making quick work of network
61 clients, servers, and peers.  A simple stand-alone web application takes
62 about 30 lines of code, most of which is your own custom logic.
63
64 %description -l pl.UTF-8
65 POE to skrót od "Perl Object Environment" (co oznacza "środowisko
66 obiektowe Perla"). Jest to szkielet obsługi sieci i wielozadaniowości
67 (nazywanej przez niektórych "kooperatywnym wątkowaniem") dla Perla.
68 Jest aktywnie rozwijane od 1996 roku, a pierwsze publiczne wydanie
69 było w 1998 roku. Na O'Reilly's Perl Conference (teraz OSCON) w 1999
70 roku POE zostało nazwane "Najlepszym nowym modułem".
71
72 POE jest używane w systemach mission-critical, takich jak
73 międzysieciowe rynki finansowe, systemy plików, serwery aplikacji i
74 handlowe. Jest używane w projektach o rozmiarach od kilku linii do
75 dziesiątek tysięcy.
76
77 POE jest kompatybilne z Perlem od wersji 5.005_03.
78
79 POE zawiera rozwijający się szkielet komponentów. Komponenty to
80 wysokopoziomowe, modularne, dające się wielokrotnie wykorzystywać
81 kawałki programów. Część komponentów została opublikowana w CPAN,
82 więcej można znaleźć na stronie WWW POE.
83
84 POE zawiera komponenty i biblioteki do szybkiego tworzenia klientów,
85 serwerów i partnerów sieciowych. Prosta, samodzielna aplikacja WWW
86 zajmuje około 30 linii kodu, z których większość to właściwa logika.
87
88 %prep
89 %setup -q -n %{pdir}-%{version}
90 rm -f lib/POE/Filter/HTTPD.pm{~.orig}
91
92 %build
93 %{__perl} Makefile.PL \
94         INSTALLDIRS=vendor \
95         --default
96 %{__make}
97
98 %{?with_tests:%{__make} test}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/POE/{Component/CD,Session}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT%{_examplesdir}
107 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc CHANGES HISTORY README TODO
115 %{perl_vendorlib}/*.pm
116 %{perl_vendorlib}/POE
117 %dir %{_examplesdir}/%{name}-%{version}
118 %{_examplesdir}/%{name}-%{version}/README*
119 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.perl
120 %{_mandir}/man3/*
This page took 0.096577 seconds and 3 git commands to generate.