]> git.pld-linux.org Git - packages/perl-POE-Sugar-Args.git/blob - perl-POE-Sugar-Args.spec
a51295d79069c34a9dd41ca4154e6913ba6ff4da
[packages/perl-POE-Sugar-Args.git] / perl-POE-Sugar-Args.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 %define         pnam    Sugar-Args
8 Summary:        POE::Sugar::Args - get "pretty", OO representation of args
9 Summary(pl.UTF-8):      POE::Sugar::Args - "ładna", obiektowo zorientowana reprezentacja argumentów
10 Name:           perl-POE-Sugar-Args
11 Version:        1.3
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  99b1a0c0abb3a25353603bb79be7d005
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Devel-Caller-Perl
22 BuildRequires:  perl-Exporter-Lite
23 BuildRequires:  perl-POE
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module give an OO representation to arguments POE passes to event
30 states. I will not lie to you. This adds heavy, bulky code underneath.
31 On the other hand, it makes arguments for POE events much more
32 palatable. Of course, this is a Sugar module, meaning, it will rot
33 your program in odd (you'll be hooked) and unexpected ways
34 (performace), but you took the candy so you can suffer the
35 consequences. Good luck.
36
37 %description -l pl.UTF-8
38 Ten moduł nadaje obiektowo zorientowaną reprezentację argumentom,
39 które POE przekazuje do stanów zdarzeń. Autor nie zamierza kłamać -
40 ten moduł dodaje ciężki, masywny kod. Z drugiej strony, czyni
41 argumenty zdarzeń POE bardziej smacznymi. Oczywiście jest to moduł
42 Sugar (cukier), co oznacza, że program zgnije w dziwny i nieoczekiwany
43 sposób (wydajność), ale używający tego modułu bierze cukierek i może
44 znosić konsekwencje. Powodzenia.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 touch Makefile.PL
51 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"POE::Sugar::Args",PL_FILES=>{})' \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %{perl_vendorlib}/%{pdir}/*
69 %{_mandir}/man3/*
This page took 0.157345 seconds and 2 git commands to generate.