]> git.pld-linux.org Git - packages/perl-POE-Filter-Ls.git/blob - perl-POE-Filter-Ls.spec
use generic url
[packages/perl-POE-Filter-Ls.git] / perl-POE-Filter-Ls.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    POE
6 %define         pnam    Filter-Ls
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        POE::Filter::Ls - translates common ls formats into a hashref
9 Summary(pl.UTF-8):      POE::Filter::Ls - tłumaczenie popularnych formatów ls na hashref
10 Name:           perl-POE-Filter-Ls
11 Version:        0.01
12 Release:        1
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  08614fffae9133995ad3dc3317959190
17 URL:            http://search.cpan.org/dist/POE-Filter-Ls/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-POE
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 POE::Filter::Ls translates common ls formats into a hashref.
28
29 %description -l pl.UTF-8
30 POE::Filter::Ls tłumaczy popularne formaty ls na hashref.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_examplesdir}
48 cp -r samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorlib}/%{pdir}/*/*.pm
57 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
58 %{_mandir}/man3/*
This page took 0.173235 seconds and 3 git commands to generate.