]> git.pld-linux.org Git - packages/perl-POE-Component-Server-XMLRPC.git/blob - perl-POE-Component-Server-XMLRPC.spec
use generic url
[packages/perl-POE-Component-Server-XMLRPC.git] / perl-POE-Component-Server-XMLRPC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    POE
6 %define         pnam    Component-Server-XMLRPC
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        POE::Component::Server::XMLRPC - publish POE event handlers via XMLRPC over HTTP
9 Summary(pl.UTF-8):      POE::Component::Server::XMLRPC - procedury obsługi POE przez XMLRPC po HTTP
10 Name:           perl-POE-Component-Server-XMLRPC
11 Version:        0.05
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  263fd98df07331d64be5beb75b07835a
18 URL:            http://search.cpan.org/dist/POE-Component-Server-XMLRPC/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-POE >= 0.22
23 BuildRequires:  perl-POE-Component-Server-HTTP >= 0.02
24 BuildRequires:  perl-SOAP-Lite >= 0.28
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 POE::Component::Server::XMLRPC adds asynchronous, event driven XMLRPC
31 over HTTP to your POE applications. It works very well with
32 synchronous XMLRPC::Lite clients, even.
33
34 %description -l pl.UTF-8
35 POE::Component::Server::XMLRPC dodaje asynchroniczne, sterowane
36 zdarzeniami XMLRPC po HTTP do aplikacji POE. Działa bardzo dobrze
37 nawet z synchronicznymi klientami XMLRPC::Lite.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_examplesdir}
55 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %{perl_vendorlib}/%{pdir}/*/*/*.pm
63 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
64 %{_mandir}/man3/*
This page took 0.03616 seconds and 3 git commands to generate.