]> git.pld-linux.org Git - packages/perl-POE-Component-SMTP.git/blob - perl-POE-Component-SMTP.spec
use generic url
[packages/perl-POE-Component-SMTP.git] / perl-POE-Component-SMTP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    POE
6 %define         pnam    Component-SMTP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        POE::Filter::SMTP - SMTP protocol filter
9 Summary(pl.UTF-8):      POE::Filter::SMTP - filtr dla protokołu SMTP
10 Name:           perl-POE-Component-SMTP
11 Version:        1.6
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  26c8d3705ef2bb9ac3d6d980ee5da73d
18 URL:            http://search.cpan.org/dist/POE-Component-SMTP/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-POE
23 BuildRequires:  perl-POE-Session-MultiDispatch
24 BuildRequires:  perl-Test-Simple
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 POE::Filter::SMTP filters input and output and splits command and
31 arguments, as well as return codes and return strings. It is a
32 subclass of POE::Filter::Line.
33
34 %description -l pl.UTF-8
35 POE::Filter::SMTP filtruje wejście i wyjście oraz oddziela polecenia i
36 argumenty, a także zwracane kody i łańcuchy. Jest to podklasa
37 POE::Filter::Line.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/%{pdir}/*/*.pm
62 %{perl_vendorlib}/%{pdir}/*/*/*.pm
63 %{_mandir}/man3/*
This page took 0.086304 seconds and 3 git commands to generate.