]> git.pld-linux.org Git - packages/perl-POE-Component-JobQueue.git/blob - perl-POE-Component-JobQueue.spec
use generic url
[packages/perl-POE-Component-JobQueue.git] / perl-POE-Component-JobQueue.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    POE
6 %define         pnam    Component-JobQueue
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        POE::Component::JobQueue - a component to manage queues and worker pools
9 Summary(pl.UTF-8):      POE::Component::JobQueue - komponent do zarządzania kolejkami i robotnikami
10 Name:           perl-POE-Component-JobQueue
11 Version:        0.571
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4b6d96b08ac72fb4ba131017f36407a2
18 URL:            http://search.cpan.org/dist/POE-Component-JobQueue/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-POE >= 1:1.007
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 POE::Component::JobQueue manages a finite pool of worker sessions as
29 they handle an arbitrarily large number of tasks. It often is used as
30 a form of flow control, preventing a large group of tasks from
31 exhausting some sort of resource.
32
33 %description -l pl.UTF-8
34 POE::Component::JobQueue zarządza skończoną pulą sesji robotników
35 wykonujących dowolnie dużą liczbę zadań. Jest często używany jako
36 forma kontroli przepływu, nie pozwalając dużej grupie zadań na
37 wyczerpanie jakiegoś rodzaju zasobu.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES
61 %{perl_vendorlib}/%{pdir}/*/*.pm
62 %{_mandir}/man3/*
This page took 0.102263 seconds and 3 git commands to generate.