]> git.pld-linux.org Git - packages/perl-POE-Component-JobQueue.git/blob - perl-POE-Component-JobQueue.spec
9def14b3b705b80ba064a03c705993ed0c2d6d4d
[packages/perl-POE-Component-JobQueue.git] / perl-POE-Component-JobQueue.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 %define         pnam    Component-JobQueue
8 Summary:        POE::Component::JobQueue - a component to manage queues and worker pools
9 Summary(pl.UTF-8):      POE::Component::JobQueue - komponent do zarządzania kolejkami i robotnikami
10 Name:           perl-POE-Component-JobQueue
11 Version:        0.571
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4b6d96b08ac72fb4ba131017f36407a2
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-POE >= 1:1.007
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 POE::Component::JobQueue manages a finite pool of worker sessions as
28 they handle an arbitrarily large number of tasks.  It often is used as
29 a form of flow control, preventing a large group of tasks from
30 exhausting some sort of resource.
31
32 %description -l pl.UTF-8
33 POE::Component::JobQueue zarządza skończoną pulą sesji robotników
34 wykonujących dowolnie dużą liczbę zadań. Jest często używany jako
35 forma kontroli przepływu, nie pozwalając dużej grupie zadań na
36 wyczerpanie jakiegoś rodzaju zasobu.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES
60 %{perl_vendorlib}/%{pdir}/*/*.pm
61 %{_mandir}/man3/*
This page took 0.047575 seconds and 2 git commands to generate.