]> git.pld-linux.org Git - packages/perl-POE-Component-Jabber.git/blob - perl-POE-Component-Jabber.spec
fe70dcb9b5ab135fa7ceccf689af6e6b6b269bb9
[packages/perl-POE-Component-Jabber.git] / perl-POE-Component-Jabber.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 %define         pnam    Component-Jabber
8 Summary:        POE::Component::Jabber - POE component for accessing Jabber servers
9 Summary(pl.UTF-8):      POE::Component::Jabber - komponent POE do dostępu do serwerów Jabbera
10 Name:           perl-POE-Component-Jabber
11 Version:        1.21
12 Release:        2
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  75196e23db297a2b07b1d58a866b03d7
17 Patch0:         %{name}-const.patch
18 Patch1:         %{name}-examples.patch
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  perl-Module-Build
22 %if %{with tests}
23 BuildRequires:  perl-Digest-SHA1 >= 2.11
24 BuildRequires:  perl-Jabber-Connection >= 0.02
25 BuildRequires:  perl-POE >= 1:0.3401
26 BuildRequires:  perl-POE-Filter-XML >= 0.29
27 BuildRequires:  perl-XML-Parser >= 2.29
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 POE::Component::Jabber is heavily based on POE::Component::IRC and
34 uses much the same event model. Authentication routines are inspired
35 by Jabber::Connection.
36
37 POE::Filter::Jabber is provided which requires XML::Parser and
38 sends and receives data as Jabber::NodeFactory::Node objects.
39
40 POE::Component::Jabber::Auth implements authentication with the
41 Jabber server. This would be a good module to look at as it
42 does it in much the way an application would interface with
43 POE::Component::Jabber by registering for the IQ event.
44
45 %description -l pl.UTF-8
46 POE::Component::Jabber jest w dużej części oparty na
47 POE::Component::IRC i używa w większości tego samego modelu. Funkcje
48 uwierzytelniania są inspirowane Jabber::Connection.
49
50 Dołączony jest POE::Filter::Jabber, wymagający XML::Parser, który
51 wysyła i odbiera dane jako obiekty Jabber::NodeFactory::Node.
52
53 POE::Component::Jabber::Auth zawiera implementację uwierzytelniania
54 względem serwera Jabbera. To jest dobry moduł do oglądania, jako że
55 robi to podobnie jak aplikacja, która współpracowałaby z
56 POE::Component::Jabber poprzez rejestrację dla zdarzenia IQ.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60 # rpm problems fixed by following patch
61 %patch0 -p1
62 # this one allows to run examples on current poe (no POE::Preprocessor)
63 %patch1 -p1
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor \
68         destdir=$RPM_BUILD_ROOT
69
70 %{__make}
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT 
79 install -d $RPM_BUILD_ROOT%{_examplesdir}
80 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %{perl_vendorlib}/%{pdir}/*/*.pm
88 %{perl_vendorlib}/%{pdir}/Component/Jabber
89 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
90 %{_mandir}/man3/*
This page took 0.091209 seconds and 2 git commands to generate.