]> git.pld-linux.org Git - packages/perl-POE-Component-Daemon.git/blob - perl-POE-Component-Daemon.spec
d1ee3b549d2d43caaca9ff624ac1f9376ee36a37
[packages/perl-POE-Component-Daemon.git] / perl-POE-Component-Daemon.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    POE
7 %define pnam    Component-Daemon
8 Summary:        POE::Component::Daemon - Handles all the housework for a daemon
9 #Summary(pl.UTF-8):
10 Name:           perl-POE-Component-Daemon
11 Version:        0.1300
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ceb684aa01237ce2eb884fdbf81b8370
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/POE-Component-Daemon/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl(POE::API::Peek) >= 1
24 BuildRequires:  perl-POE >= 0.3202
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Dealing with all the little details of a forking daemon can be
31 annoying and hard. POE::Component::Daemon encapsulates all the details
32 into one place and (hopefully) gets them right.
33
34 POE::Component::Daemon will deal with all the annoying details of
35 creating and maintaining daemon processes. It can detach from the
36 console, handle pre-forking pools or post-forking (ie, fork on each
37 request). It will also redirect STDERR to a log file if asked.
38
39 POE::Component::Daemon also babysits child processes, handling their
40 CHLD. POE::Component::Daemon can also makes sure requests don't take
41 to long. If they do, it will try to get rid of them. See /BABYSITING
42 below.
43
44 POE::Component::Daemon does not handle listening on sockets. That is
45 up to your code.
46
47 Like all of POE, POE::Component::Daemon works cooperatively. It is up
48 your code to tell POE::Component::Daemon when it is time to fork,
49 block incoming requests when approriate and so on.
50
51 # %description -l pl.UTF-8
52 # TODO
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorlib}/POE/Component/*.pm
77 %{perl_vendorlib}/POE/Component/Daemon
78 %{_mandir}/man3/*
This page took 0.111764 seconds and 2 git commands to generate.