]> git.pld-linux.org Git - packages/perl-POE-Component-CD-Detect.git/blob - perl-POE-Component-CD-Detect.spec
dc0831ea95278e5ea9af84a4b09a546e3cd391c1
[packages/perl-POE-Component-CD-Detect.git] / perl-POE-Component-CD-Detect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    POE
7 %define         pnam    Component-CD-Detect
8 Summary:        POE::Component::CD::Detect - detects CD insertions and provides TOC
9 Summary(pl.UTF-8):      POE::Component::CD::Detect - wykrywanie włożenia CD i odczytanie TOC
10 Name:           perl-POE-Component-CD-Detect
11 Version:        1.1
12 Release:        1
13 License:        BSD-like
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  92b8377a52c3a67e9084c51ba9c2cdf2
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-POE >= 0.22
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This POE component detects the insertion of a CD into a given drive and
27 issues a callback to the caller with the disc's table of contents.
28
29 %description -l pl.UTF-8
30 Ten komponent POE wykrywa fakt włożenia płyty CD do danego napędu i
31 wywołuje funkcję callback podaną przy wywołaniu przekazując spis
32 zawartości płyty (TOC).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes LICENSE README
56 %{perl_vendorlib}/%{pdir}/Component/CD/*.pm
57 %{_mandir}/man3/*
This page took 0.059049 seconds and 2 git commands to generate.