]> git.pld-linux.org Git - packages/perl-PHP-Serialization.git/blob - perl-PHP-Serialization.spec
6e45a41f09d46a87b50c33147249f50f7f559f35
[packages/perl-PHP-Serialization.git] / perl-PHP-Serialization.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    PHP
7 %define         pnam    Serialization
8 Summary:        PHP::Serialization - converting between PHP's serialize() output and Perl memory structure equivalent
9 Summary(pl.UTF-8):      PHP::Serialization - konwersja między wyjściem serialize() z PHP i odpowiednikiem perlowych struktur w pamięci
10 Name:           perl-PHP-Serialization
11 Version:        0.34
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  333af0848ad79931875a35cc61dc22e0
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Provides a simple, quick means of serializing Perl memory structures
25 (including object data!) into a format that PHP can deserialize() and
26 access, and vice versa.
27
28 NOTE: Converts PHP arrays into Perl Arrays when the PHP array used
29 exclusively numeric indexes, and into Perl Hashes when the PHP array
30 did not.
31
32 %description -l pl.UTF-8
33 Ten moduł dostarcza proste, szybkie środki do serializacji struktur
34 perlowych w pamięci (włącznie z danymi obiektów!) na format nadający
35 się do dostępu i deserialize() w PHP oraz w drugą stronę.
36
37 UWAGA: konwertuje tablice PHP na tablice perlowe, kiedy tablica PHP
38 używa wyłącznie numerycznych indeksów, a na perlowe tablice
39 asocjacyjne w przeciwnym wypadku.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes
63 %{perl_vendorlib}/PHP/*.pm
64 %{_mandir}/man3/*
This page took 0.053727 seconds and 2 git commands to generate.