]> git.pld-linux.org Git - packages/perl-PDFLib.git/blob - perl-PDFLib.spec
use generic url
[packages/perl-PDFLib.git] / perl-PDFLib.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pnam    PDFLib
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        PDFLib Perl module - simpler and more OO interface to pdflib
8 Summary(pl.UTF-8):      Moduł Perla PDFLib - prostszy i bardziej obiektowy interfejs do pdflib-a
9 Name:           perl-PDFLib
10 Version:        0.14
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MS/MSERGEANT/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e22be28ee9a06c790484fdadf0558c82
17 Patch0:         %{name}-pdflib4.patch
18 URL:            http://search.cpan.org/dist/-PDFLib/
19 BuildRequires:  pdflib-perl >= 4.0.3-11
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       pdflib-perl >= 4.0.3-11
23 #Suggests:      pdflib-perl >= 5
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 PDFLib is a simpler, more OO interface to pdflib, available from
29 http://www.pdflib.com/. It makes creating PDFs from Perl fast, easy
30 and safe. Currently it supports text, images, graphics, and
31 getting/setting all parameters. It has builting support for several
32 paper sizes. It also takes care of starting/ending new pages, to try
33 and make sure that a valid PDF file is always created.
34
35 %description -l pl.UTF-8
36 PDFLib to prostszy, bardziej obiektowo zorientowany interfejs do
37 pdflib-a, dostępnego na http://www.pdflib.com/. Moduł ten czyni
38 tworzenie PDF-ów z Perla szybkim, łatwnym i bezpiecznym. Aktualnie
39 obsługuje tekst, obrazki, grafikę i odczytywanie/ustawianie wszystkich
40 parametrów. Ma wbudowaną obsługę kilku rozmiarów papieru. Moduł dba o
41 rozpoczynanie/kończenie stron, próbuje też zapewnić, aby zawsze był
42 tworzony poprawny PDF.
43
44 %prep
45 %setup -q -n %{pnam}-%{version}
46 %patch0 -p1
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorlib}/PDFLib.pm
68 %{_mandir}/man3/*
This page took 0.297452 seconds and 3 git commands to generate.