]> git.pld-linux.org Git - packages/perl-OpenGL.git/blob - perl-OpenGL.spec
- release 6 (by relup.sh)
[packages/perl-OpenGL.git] / perl-OpenGL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        OpenGL - Perl module to display 3D data using OpenGL, GLU, GLUT, and GLX
7 Summary(pl.UTF-8):      OpenGL - moduł Perla przedstawiający dane korzystając z bibliotek OpenGL, GLU, GLUT i GLX
8 Name:           perl-OpenGL
9 Version:        0.66
10 Release:        6
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/C/CH/CHM/OpenGL-%{version}.tar.gz
15 # Source0-md5:  bdfbffb31f03acbfb6d0123ceb159436
16 Patch0:         %{name}-build.patch
17 URL:            http://search.cpan.org/dist/OpenGL/
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  freeglut-devel
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module provides access to most of the OpenGL 1.0, 1.1, and 1.2
26 APIs. Some amount of GLU is supported (I'm not quite sure what version
27 it works out to), and GLUT should be completely supported up to API
28 version 3. A small portion of GLX and X11 is supported, as an
29 alternative to GLUT.
30
31 %description -l pl.UTF-8
32 Ten moduł daje dostęp do większości API OpenGL 1.0, 1.1 i 1.2.
33 Udostępnia też część GLU (w bliżej nieokreślonej wersji) oraz
34 powinien udostępniać pełne API GLUT do wersji 3. Jako alternatywa
35 dla GLUT jest dostępna także niewielka część API GLX i X11.
36
37 %prep
38 %setup -q -n OpenGL-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         interface=FREEGLUT \
44         INSTALLDIRS=vendor
45
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55 mkdir -p $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 cp examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README SUPPORTS TODO COPYRIGHT
64 %{perl_vendorarch}/OpenGL.pm
65 %dir %{perl_vendorarch}/OpenGL
66 %{perl_vendorarch}/OpenGL/Config.pm
67 %dir %{perl_vendorarch}/auto/OpenGL
68 %{perl_vendorarch}/auto/OpenGL/autosplit.ix
69 %attr(755,root,root) %{perl_vendorarch}/auto/OpenGL/*.so
70 %dir %{_examplesdir}/%{name}-%{version}
71 %{_mandir}/man3/*.3pm*
72 %{_examplesdir}/%{name}-%{version}/*
This page took 0.118025 seconds and 3 git commands to generate.