]> git.pld-linux.org Git - packages/perl-Net-xAP.git/blob - perl-Net-xAP.spec
use generic url
[packages/perl-Net-xAP.git] / perl-Net-xAP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires IMAP server)
4
5 %define         pdir    Net
6 %define         pnam    xAP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::xAP Perl module - interface to IMAP/ACAP/IMSP/ICAP protocol family
9 Summary(pl.UTF-8):      Moduł Perla Net::xAP - interfejs do rodziny protokołów IMAP/ACAP/IMSP/ICAP
10 Name:           perl-Net-xAP
11 Version:        0.02
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}%{pnam}-%{version}.tar.gz
17 # Source0-md5:  df6ddaa8dad8d366784bf9a2a1f8eed1
18 URL:            http://search.cpan.org/dist/Net-xAP/
19 BuildRequires:  perl-Digest-HMAC
20 BuildRequires:  perl-MIME-Base64 >= 2.11
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       perl-Digest-MD5 >= 2.01
24 Requires:       perl-MIME-Base64 >= 2.11
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides an interface to the protocol family represented
30 by IMAP, IMSP, ACAP, and ICAP. A usable IMAP module is also provide.
31 Warning: this is an alpha release!
32
33 %description -l pl.UTF-8
34 Ten moduł udostępnia interfejs do rodziny protokołów reprezentowanej
35 przez IMAP, IMSP, ACAP i ICAP. Dołączony jest także używalny moduł
36 IMAP. Uwaga: to jest wersja alpha!
37
38 %prep
39 %setup -q -n %{pdir}%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc ANNOUNCE BUGS CREDITS NEWS README TODO
62 %{perl_vendorlib}/Net/*.pm
63 %{_mandir}/man3/*
64 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.067983 seconds and 3 git commands to generate.