]> git.pld-linux.org Git - packages/perl-Net-UPnP.git/blob - perl-Net-UPnP.spec
- new
[packages/perl-Net-UPnP.git] / perl-Net-UPnP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    UPnP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::UPnP - Perl extension for UPnP
9 Name:           perl-Net-UPnP
10 Version:        1.4.2
11 Release:        1
12 License:        BSD
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  bc009fd76b565df40a70aca49af82a7d
16 URL:            http://search.cpan.org/dist/Net-UPnP/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This package provides some functions to control UPnP devices.
24
25 Currently, the package provides only functions for the control point.  
26 To control UPnP devices, see Net::UPnP::ControlPoint.
27
28 As a sample of the control point, the package provides 
29 Net::UPnP::AV::MediaServer to control the devices such as
30 DLNA media servers. As the example, please dms2vodcast.pl
31 that converts from the MPEG2 movies to the MPEG4 one and 
32 outputs the RSS file for Vodcasting.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/Net/*.pm
60 %{perl_vendorlib}/Net/UPnP
61 %{_mandir}/man3/*
62 %{_examplesdir}/%{name}-%{version}
This page took 0.066803 seconds and 3 git commands to generate.