]> git.pld-linux.org Git - packages/perl-Net-SSH2.git/blob - perl-Net-SSH2.spec
use generic url
[packages/perl-Net-SSH2.git] / perl-Net-SSH2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SSH2
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::SSH2 Perl module
9 Summary(cs.UTF-8):      Modul Net::SSH2 pro Perl
10 Summary(da.UTF-8):      Perlmodul Net::SSH2
11 Summary(de.UTF-8):      Net::SSH2 Perl Modul
12 Summary(es.UTF-8):      Módulo de Perl Net::SSH2
13 Summary(fr.UTF-8):      Module Perl Net::SSH2
14 Summary(it.UTF-8):      Modulo di Perl Net::SSH2
15 Summary(ja.UTF-8):      Net::SSH2 Perl モジュール
16 Summary(ko.UTF-8):      Net::SSH2 펄 모줄
17 Summary(nb.UTF-8):      Perlmodul Net::SSH2
18 Summary(pl.UTF-8):      Moduł Perla Net::SSH2
19 Summary(pt.UTF-8):      Módulo de Perl Net::SSH2
20 Summary(pt_BR.UTF-8):   Módulo Perl Net::SSH2
21 Summary(ru.UTF-8):      Модуль для Perl Net::SSH2
22 Summary(sv.UTF-8):      Net::SSH2 Perlmodul
23 Summary(uk.UTF-8):      Модуль для Perl Net::SSH2
24 Summary(zh_CN.UTF-8):   Net::SSH2 Perl 模块
25 Name:           perl-Net-SSH2
26 Version:        0.53
27 Release:        3
28 # same as perl
29 License:        GPL v1+ or Artistic
30 Group:          Development/Languages/Perl
31 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
32 # Source0-md5:  f8a2c3ebb3bd191635e00a68a3d5f015
33 URL:            http://search.cpan.org/dist/Net-SSH2/
34 BuildRequires:  libssh2-devel
35 BuildRequires:  openssl-devel
36 BuildRequires:  perl-devel >= 1:5.8.0
37 BuildRequires:  rpm-perlprov >= 4.1-13
38 BuildRequires:  zlib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Net::SSH2 is a perl interface to the libssh2 (http://www.libssh2.org)
43 library. It supports the SSH2 protocol (there is no support for SSH1)
44 with all of the key exchanges, ciphers, and compression of libssh2.
45
46 %description -l pl.UTF-8
47 Net::SSH - interfejs do biblioteki libssh2 (http://www.libssh2.org).
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README TODO example/read.pl
71 %{perl_vendorarch}/Net/SSH2.pm
72 %{perl_vendorarch}/Net/SSH2
73 %dir %{perl_vendorarch}/auto/Net/SSH2
74 %{perl_vendorarch}/auto/Net/SSH2/autosplit.ix
75 %attr(755,root,root) %{perl_vendorarch}/auto/Net/SSH2/SSH2.so
76 %{_mandir}/man3/*
This page took 0.147309 seconds and 3 git commands to generate.