]> git.pld-linux.org Git - packages/perl-Net-PcapUtils.git/blob - perl-Net-PcapUtils.spec
use generic url
[packages/perl-Net-PcapUtils.git] / perl-Net-PcapUtils.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # require UID=0
5
6 %define         pdir    Net
7 %define         pnam    PcapUtils
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Perl Net::PcapUtils module
10 Summary(pl.UTF-8):      Moduł perla Net::PcapUtils
11 Name:           perl-Net-PcapUtils
12 Version:        0.01
13 Release:        6
14 License:        free
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  eeba67266dbe155b504df3c2de1d657f
18 URL:            http://search.cpan.org/dist/Net-PcapUtils/
19 BuildRequires:  libpcap-devel
20 BuildRequires:  perl-Net-Pcap
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides some code to abstract away some of the messier
28 parts of using the Net::Pcap library. The idea is to be able to write
29 "one-liner" type scripts for packet capture without getting bogged
30 down in the initialisation code. This makes it possible to write very
31 compact Perl scripts involving packet capture.
32
33 %description -l pl.UTF-8
34 Ten moduł dostarcza trochę kodu by oddalić bardziej zawiłe części
35 używania biblioteki Net::Pcap. Idea jest taka, by móc pisać skrypty
36 jednolinijkowe do przechwytywania pakietów bez zakopywania się w kod
37 inicjalizujący. Pozwala to na pisanie bardzo krótkich skryptów
38 perlowych przechwytujących pakiety.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55 find $RPM_BUILD_ROOT -name .packlist | xargs -r rm -f
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README
63 %{perl_vendorlib}/%{pdir}/%{pnam}.pm
64 %{_mandir}/man3/*
This page took 0.054515 seconds and 3 git commands to generate.