]> git.pld-linux.org Git - packages/perl-Net-Patricia.git/blob - perl-Net-Patricia.spec
rebuild with perl 5.32
[packages/perl-Net-Patricia.git] / perl-Net-Patricia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    Patricia
7 Summary:        Net::Patricia - Patricia Trie Perl module for fast IP address lookups
8 Summary(pl.UTF-8):      Net::Patricia - moduł Perla Patricia Trie do szybkiego wyszukiwania adresów IP
9 Name:           perl-Net-Patricia
10 Version:        1.22
11 Release:        11
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  ef838f7512b050ca4b35d742f9565b3b
16 Patch0:         %{name}-link.patch
17 URL:            https://metacpan.org/release/Net-Patricia
18 BuildRequires:  perl-Net-CIDR-Lite >= 0.20
19 BuildRequires:  perl-Socket6
20 BuildRequires:  perl-devel >= 1:5.8.0
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple >= 0.88
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  rpmbuild(macros) >= 1.745
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module uses a Patricia Trie data structure to quickly perform IP
30 address prefix matching for applications such as IP subnet, network or
31 routing table lookups.
32
33 The data structure is based on a radix tree using a radix of two,
34 so sometimes you see patricia implementations called "radix" as well.
35 The term "Trie" is derived from the word "retrieval" but is pronounced
36 like "try".  Patricia stands for "Practical Algorithm to Retrieve
37 Information Coded as Alphanumeric", and was first suggested for
38 routing table lookups by Van Jacobsen. Patricia Trie performance
39 characteristics are well-known as it has been employed for routing
40 table lookups within the BSD kernel since the 4.3 Reno release.
41
42 %description -l pl.UTF-8
43 Ten moduł używa struktury danych Patricia Trie do wykonywania
44 szybkiego dopasowywania prefiksów IP dla zastosowań takich jak
45 przeszukiwanie podsieci IP, sieci czy tabel routingu.
46
47 Struktura danych jest oparta na drzewie radix przy podstawie
48 wynoszącej 2 - implementacje patricia czasem są nazywane także radix.
49 Termin "Trie" pochodzi od słowa "retrieval" (odczytywanie), ale jest
50 wymawiany jak "try". Patricia to skrót od "Practical Algorithm to
51 Retrieve Information Coded as Alphanumeric" (praktyczny algorytm
52 odczytywania informacji zakodowanych alfanumerycznie) i jako
53 pierwszy zaproponowany do przeszukiwania tabel routingu przez Van
54 Jacobsena. Charakterystyki wydajności Patricia Trie są dobrze znane,
55 jako że struktura ta jest wykorzystywana przy przeszukiwaniu tabel
56 routingu w jądrze BSD od wersji 4.3 Reno.
57
58 %prep
59 %setup -q -n %{pdir}-%{pnam}-%{version}
60 %patch0 -p1
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make} \
66         CC="%{__cc}" \
67         OPTIMIZE="%{rpmcflags}"
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc Changes README
83 %{perl_vendorarch}/Net/Patricia.pm
84 %dir %{perl_vendorarch}/auto/Net/Patricia
85 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Patricia/Patricia.so
86 %{_mandir}/man3/Net::Patricia.3pm*
This page took 0.070271 seconds and 3 git commands to generate.