]> git.pld-linux.org Git - packages/perl-Net-Patricia.git/blob - perl-Net-Patricia.spec
- release 4 (by relup.sh)
[packages/perl-Net-Patricia.git] / perl-Net-Patricia.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    Patricia
8 Summary:        Net::Patricia - Patricia Trie Perl module for fast IP address lookups
9 Summary(pl.UTF-8):      Net::Patricia - moduł Perla Patricia Trie do szybkiego wyszukiwania adresów IP
10 Name:           perl-Net-Patricia
11 Version:        1.22
12 Release:        4
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/G/GR/GRUBER/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ef838f7512b050ca4b35d742f9565b3b
17 URL:            http://search.cpan.org/dist/Net-Patricia/
18 BuildRequires:  perl-Net-CIDR-Lite
19 BuildRequires:  perl-Socket6
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module uses a Patricia Trie data structure to quickly perform IP
26 address prefix matching for applications such as IP subnet, network or
27 routing table lookups.
28
29 The data structure is based on a radix tree using a radix of two,
30 so sometimes you see patricia implementations called "radix" as well.
31 The term "Trie" is derived from the word "retrieval" but is pronounced
32 like "try".  Patricia stands for "Practical Algorithm to Retrieve
33 Information Coded as Alphanumeric", and was first suggested for
34 routing table lookups by Van Jacobsen. Patricia Trie performance
35 characteristics are well-known as it has been employed for routing
36 table lookups within the BSD kernel since the 4.3 Reno release.
37
38 %description -l pl.UTF-8
39 Ten moduł używa struktury danych Patricia Trie do wykonywania
40 szybkiego dopasowywania prefiksów IP dla zastosowań takich jak
41 przeszukiwanie podsieci IP, sieci czy tabel routingu.
42
43 Struktura danych jest oparta na drzewie radix przy podstawie
44 wynoszącej 2 - implementacje patricia czasem są nazywane także radix.
45 Termin "Trie" pochodzi od słowa "retrieval" (odczytywanie), ale jest
46 wymawiany jak "try". Patricia to skrót od "Practical Algorithm to
47 Retrieve Information Coded as Alphanumeric" (praktyczny algorytm
48 odczytywania informacji zakodowanych alfanumerycznie) i jako
49 pierwszy zaproponowany do przeszukiwania tabel routingu przez Van
50 Jacobsena. Charakterystyki wydajności Patricia Trie są dobrze znane,
51 jako że struktura ta jest wykorzystywana przy przeszukiwaniu tabel
52 routingu w jądrze BSD od wersji 4.3 Reno.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make} \
61         CC="%{__cc}" \
62         OPTIMIZE="%{rpmcflags}"
63
64 %{?with_tests:%{__make} test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc Changes README
78 %{perl_vendorarch}/Net/*.pm
79 %dir %{perl_vendorarch}/auto/Net/Patricia
80 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Patricia/Patricia.so
81 %{_mandir}/man3/*
This page took 0.088764 seconds and 3 git commands to generate.