]> git.pld-linux.org Git - packages/perl-Net-OAuth.git/blob - perl-Net-OAuth.spec
169861b1bdf169128c1c42c17315dbce01b88c85
[packages/perl-Net-OAuth.git] / perl-Net-OAuth.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    OAuth
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::OAuth - OAuth protocol support
9 #Summary(pl.UTF-8):
10 Name:           perl-Net-OAuth
11 Version:        0.28
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/K/KG/KGRENNAN/Net-OAuth-%{version}.tar.gz
17 # Source0-md5:  336d7fb22e945f014e1bce0f49fcfad9
18 URL:            http://search.cpan.org/dist/Net-OAuth/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-Accessor >= 0.31
23 BuildRequires:  perl-Class-Data-Inheritable >= 0.06
24 BuildRequires:  perl-Digest-HMAC >= 1.01
25 BuildRequires:  perl-Digest-SHA1 >= 2.12
26 BuildRequires:  perl-Encode
27 BuildRequires:  perl-Test-Warn >= 0.21
28 BuildRequires:  perl-URI
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 An OAuth message is a set of key-value pairs. The following message
35 types are supported:
36 - Requests
37 - Responses
38
39 Each OAuth message type has one or more required parameters, zero or
40 more optional parameters, and most allow arbitrary parameters.
41
42 All OAuth requests must be signed by the Consumer. Responses from the
43 Service Provider, however, are not signed.
44
45 # %description -l pl.UTF-8
46 # TODO
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Build.PL \
53         destdir=$RPM_BUILD_ROOT \
54         installdirs=vendor
55 ./Build
56
57 %{?with_tests:./Build test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 ./Build install
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Net/*.pm
71 %{perl_vendorlib}/Net/OAuth
72 %{_mandir}/man3/*
This page took 0.049219 seconds and 2 git commands to generate.