]> git.pld-linux.org Git - packages/perl-Net-MQTT-Simple.git/blob - perl-Net-MQTT-Simple.spec
- initial, version 1.26
[packages/perl-Net-MQTT-Simple.git] / perl-Net-MQTT-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    MQTT-Simple
7 Summary:        Net::MQTT::Simple - Minimal MQTT version 3 interface
8 Summary(pl.UTF-8):      Net::MQTT::Simple - minimalistyczny interfejs do MQTT w wersji 3
9 Name:           perl-Net-MQTT-Simple
10 Version:        1.26
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a2c6fa5b0f4eba18da80b8d68f798768
17 URL:            http://search.cpan.org/dist/Net-MQTT-Simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Test::More)
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module consists of only one file and has no dependencies except
28 core Perl modules, making it suitable for embedded installations where
29 CPAN installers are unavailable and resources are limited.
30
31 Only basic MQTT functionality is provided; if you need more, you'll
32 have to use the full-featured Net::MQTT instead.
33
34 Connections are set up on demand, automatically reconnecting to the
35 server if a previous connection had been lost.
36
37 Because sensor scripts often run unattended, connection failures will
38 result in warnings (on STDERR if you didn't override that) without
39 throwing an exception.
40
41 Please refer to Net::MQTT::Simple::SSL for more information about
42 encrypted and authenticated connections.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %dir %{perl_vendorlib}/Net/MQTT/Simple
68 %{perl_vendorlib}/Net/MQTT/Simple.pm
69 %{perl_vendorlib}/Net/MQTT/Simple/SSL.pm
70 %attr(755,root,root) %{_bindir}/mqtt-simple
71 %{_mandir}/man1/*.1*
72 %{_mandir}/man3/*.3*
This page took 0.046756 seconds and 3 git commands to generate.