]> git.pld-linux.org Git - packages/perl-Net-Jabber.git/blob - perl-Net-Jabber.spec
use generic url
[packages/perl-Net-Jabber.git] / perl-Net-Jabber.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network!)
4
5 %define         pdir    Net
6 %define         pnam    Jabber
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::Jabber Perl module - access to the Jabber protocol
9 Summary(pl.UTF-8):      Moduł Perla Net::Jabber - dostęp do protokołu Jabbera
10 Name:           perl-Net-Jabber
11 Version:        2.0
12 Release:        2
13 License:        LGPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1fd348fb9a1a6c5a167ae862ed89cd53
17 URL:            http://search.cpan.org/dist/Net-Jabber/
18 BuildRequires:  perl-Digest-SHA1 >= 1.02
19 BuildRequires:  perl-XML-Stream >= 1.17
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Net::Jabber is a collection of Perl modules that provide a Perl
27 Developer access to the Jabber protocol. Using OOP modules they
28 provide a clean interface to writing anything from a full client to a
29 simple protocol tester.
30
31 %description -l pl.UTF-8
32 Net::Jabber to zbiór modułów Perla dających programiście perlowemu
33 dostęp do protokołu Jabbera. Zorientowane obiektowo moduły dają czysty
34 interfejs do pisania wszystkiego od pełnego klienta do prostego
35 testera protokołu.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %{__perl} -pi -e 's/^(use 5.006_)0(01;)(.*)$/$1$2$3/' Jabber/X.pm
40
41 %build
42 echo -e "y\ny\ny\n" | perl Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}
51
52 %{__make} install \
53         UNINST=0 \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README CHANGES
62 %{perl_vendorlib}/Net/*
63 %{_mandir}/man3/*
This page took 0.075191 seconds and 3 git commands to generate.