]> git.pld-linux.org Git - packages/perl-Net-HTTP.git/blob - perl-Net-HTTP.spec
72432870d89d632d55649d42a2d328b6af61c064
[packages/perl-Net-HTTP.git] / perl-Net-HTTP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test" (uses network)
4 #
5 %define         pdir    Net
6 %define         pnam    HTTP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Net::HTTP - Low-level HTTP connection (client)
9 Summary(pl.UTF-8):      Net::HTTP - nieskopoziomowe połączenie HTTP (klient)
10 Name:           perl-Net-HTTP
11 Version:        6.18
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  6da11a7db0e933b7684148e1fb32006a
18 URL:            http://search.cpan.org/dist/Net-HTTP/
19 BuildRequires:  perl-devel >= 1:5.8.8
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-IO-Compress
23 %endif
24 Suggests:       perl-IO-Socket-SSL >= 2.012
25 Conflicts:      perl-libwww < 6
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Net::HTTP class is a low-level HTTP client. An instance of the
31 Net::HTTP class represents a connection to an HTTP server. The HTTP
32 protocol is described in RFC 2616. The Net::HTTP class supports
33 HTTP/1.0 and HTTP/1.1.
34
35 %description -l pl.UTF-8
36 Klasa Net::HTTP jest niskopoziomowym klientem HTTP. Instancja tej
37 klasy reprezentuje połączenie z serwerem HTTP. Protokół HTTP jest
38 opisany w RFC 2616. Klasa Net::HTTP obsługuje HTTP/1.0 i HTTP/1.1.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes
62 %{perl_vendorlib}/Net/HTTP.pm
63 %{perl_vendorlib}/Net/HTTPS.pm
64 %{perl_vendorlib}/Net/HTTP
65 %{_mandir}/man3/Net::HTTP*.3pm*
This page took 0.054934 seconds and 2 git commands to generate.