]> git.pld-linux.org Git - packages/perl-Net-FTP-Common.git/blob - perl-Net-FTP-Common.spec
6564361603a430d279d143686c937493251cd911
[packages/perl-Net-FTP-Common.git] / perl-Net-FTP-Common.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network!)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    FTP-Common
8 Summary:        Net::FTP::Common - simplify common usages of Net::FTP
9 Summary(pl.UTF-8):      Net::FTP::Common - uproszczenie popularnych sposobów użycia Net::FTP
10 Name:           perl-Net-FTP-Common
11 Version:        7.0.d
12 Release:        1
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  15b1b719b5ac26a0122775c2e68c7d5c
17 %{?with_tests:BuildRequires:    perl(Net::FTP) >= 1}
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 # for Net::FTP and directory
21 Requires:       perl-libnet
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module is intended to make the common uses of Net::FTP a
27 one-line, no-argument affair. In other words, you have 100%
28 programming with Net::FTP. With Net::FTP::Common you will have 95%
29 configuration and 5% programming.
30
31 %description -l pl.UTF-8
32 Ten moduł ma uczynić popularne sposoby użycia Net::FTP
33 jednolinijkowymi wywołaniami bez argumentów. Innymi słowy, przy użyciu
34 Net::FTP mamy 100% programowania. Przy użyciu Net::FTP::Common mamy
35 95% konfiguracji i 5% programowania.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 cp -a samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc ChangeLog README
62 %{perl_vendorlib}/TestConfig.pm
63 %{perl_vendorlib}/%{pdir}/FTP/Common.pm
64 %{_mandir}/man3/*
65 %{_examplesdir}/%{name}-%{version}
This page took 0.058397 seconds and 2 git commands to generate.