]> git.pld-linux.org Git - packages/perl-Net-DNS-ToolKit.git/blob - perl-Net-DNS-ToolKit.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-DNS-ToolKit.git] / perl-Net-DNS-ToolKit.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    DNS-ToolKit
7 Summary:        Net::DNS::ToolKit - tools for working with DNS packets
8 Summary(pl.UTF-8):      Net::DNS::ToolKit - narzędzia do pracy z pakietami DNS
9 Name:           perl-Net-DNS-ToolKit
10 Version:        0.48
11 Release:        7
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  242fab98e7a4e195d63e554b42f6c12b
16 URL:            http://search.cpan.org/dist/Net-DNS-ToolKit/
17 %if %{with tests}
18 BuildRequires:  perl-Net-DNS-Codes >= 0.06
19 BuildRequires:  perl-NetAddr-IP
20 %endif
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Routines to pick apart, examine and put together DNS packets. They can
27 be used for diagnostic purposes or as building blocks for DNS
28 applications such as DNS servers and clients or to allow user
29 applications to interact directly with remote DNS servers.
30
31 %description -l pl.UTF-8
32 Procedury do wybierania, badania oraz składania pakietów DNS. Mogą być
33 użyte do celów diagnostycznych lub do tworzenia bloków dla aplikacji
34 NDS takich jak serwery oraz klienci DNS lub do umożliwienia
35 użytkownikowi do bezpośredniej interakcji ze zdalnymi serwerami DNS.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make} -j1 \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/DNS/ToolKit/.packlist
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes INSTALL README
64 %{perl_vendorarch}/Net/DNS/*.pm
65 %{perl_vendorarch}/Net/DNS/ToolKit
66 %dir %{perl_vendorarch}/auto/Net/DNS
67 %dir %{perl_vendorarch}/auto/Net/DNS/ToolKit
68 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/ToolKit/*.so
69 %{perl_vendorarch}/auto/Net/DNS/ToolKit/*.ix
70 %{perl_vendorarch}/auto/Net/DNS/ToolKit/*.al
71 %{perl_vendorarch}/auto/Net/DNS/ToolKit/Debug
72 %{perl_vendorarch}/auto/Net/DNS/ToolKit/Utilities
73 %{_mandir}/man3/*
This page took 0.072388 seconds and 3 git commands to generate.