]> git.pld-linux.org Git - packages/perl-Net-ARP.git/blob - perl-Net-ARP.spec
- release 8 (by relup.sh)
[packages/perl-Net-ARP.git] / perl-Net-ARP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test" (requires uid 0)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    ARP
8 Summary:        Perl extension for creating ARP packets
9 Summary(pl.UTF-8):      Rozszerzenie Perla do tworzenia pakietów ARP
10 Name:           perl-Net-ARP
11 Version:        1.0.6
12 Release:        8
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tgz
17 # Source0-md5:  1b71124347f23f951b96e86826af8562
18 URL:            http://search.cpan.org/dist/Net-ARP/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Net-Pcap
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module can be used to create and send ARP packets and to get the
28 MAC address of an ethernet interface or IP address.
29
30 %description -l pl.UTF-8
31 Ten moduł może być użyty do tworzenia i wysłania pakietów ARP oraz do
32 uzyskiwania adresu MAC interfejsu sieciowego lub adresu IP.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/Net/*.pm
59 %dir %{perl_vendorarch}/auto/Net/ARP
60 %attr(755,root,root) %{perl_vendorarch}/auto/Net/ARP/ARP.so
61 %{_mandir}/man3/*
This page took 0.080306 seconds and 3 git commands to generate.