]> git.pld-linux.org Git - packages/perl-MooseX-Role-WithOverloading.git/blob - perl-MooseX-Role-WithOverloading.spec
use generic url
[packages/perl-MooseX-Role-WithOverloading.git] / perl-MooseX-Role-WithOverloading.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    MooseX
6 %define         pnam    Role-WithOverloading
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        MooseX::Role::WithOverloading - Roles which support overloading
9 Name:           perl-MooseX-Role-WithOverloading
10 Version:        0.13
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/MooseX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9f00627828c22aece891b016bcf12762
17 URL:            http://search.cpan.org/dist/MooseX-Role-WithOverloading/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Moose >= 0.94
22 BuildRequires:  perl-MooseX-Types
23 BuildRequires:  perl-Test-CheckDeps
24 BuildRequires:  perl-Test-NoWarnings
25 BuildRequires:  perl-aliased
26 BuildRequires:  perl-namespace-autoclean >= 0.12
27 BuildRequires:  perl-namespace-clean
28 %endif
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 MooseX::Role::WithOverloading allows you to write a Moose::Role which
33 defines overloaded operators and allows those operator overloadings to
34 be composed into the classes/roles/instances it's compiled to, while
35 plain Moose::Roles would lose the overloading.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %dir %{perl_vendorarch}/MooseX
62 %dir %{perl_vendorarch}/MooseX/Role
63 %{perl_vendorarch}/MooseX/Role/WithOverloading
64 %{perl_vendorarch}/MooseX/Role/WithOverloading.pm
65 %dir %{perl_vendorarch}/auto/MooseX
66 %dir %{perl_vendorarch}/auto/MooseX/Role
67 %dir %{perl_vendorarch}/auto/MooseX/Role/WithOverloading
68 %attr(755,root,root) %{perl_vendorarch}/auto/MooseX/Role/WithOverloading/*.so
69 %{_mandir}/man3/*
This page took 0.059534 seconds and 3 git commands to generate.