]> git.pld-linux.org Git - packages/perl-MooseX-NonMoose.git/blob - perl-MooseX-NonMoose.spec
use generic url
[packages/perl-MooseX-NonMoose.git] / perl-MooseX-NonMoose.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    MooseX
6 %define         pnam    NonMoose
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        MooseX::NonMoose - easy subclassing of non-Moose classes
9 Name:           perl-MooseX-NonMoose
10 Version:        0.22
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/MooseX/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  08627b8575835e64b44e82424df27a8f
17 URL:            http://search.cpan.org/dist/MooseX-NonMoose/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Test::Fatal)
22 BuildRequires:  perl-List-MoreUtils
23 BuildRequires:  perl-Moose >= 1.15
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 MooseX::NonMoose allows for easily subclassing non-Moose classes with
30 Moose, taking care of the annoying details connected with doing this,
31 such as setting up proper inheritance from Moose::Object and
32 installing (and inlining, at make_immutable time) a constructor that
33 makes sure things like BUILD methods are called. It tries to be as
34 non-intrusive as possible - when this module is used, inheriting from
35 non-Moose classes and inheriting from Moose classes should work
36 identically, aside from the few caveats mentioned below. One of the
37 goals of this module is that including it in a Moose::Exporter-based
38 package used across an entire application should be possible, without
39 interfering with classes that only inherit from Moose modules, or even
40 classes that don't inherit from anything at all.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/MooseX/*.pm
65 %{perl_vendorlib}/MooseX/NonMoose
66 %{_mandir}/man3/*
This page took 0.061034 seconds and 3 git commands to generate.