]> git.pld-linux.org Git - packages/perl-MooseX-NonMoose.git/blob - perl-MooseX-NonMoose.spec
8d075621bd8ee3c669617ae6e920a1abcd491ffc
[packages/perl-MooseX-NonMoose.git] / perl-MooseX-NonMoose.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    MooseX
6 %define         pnam    NonMoose
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        MooseX::NonMoose - easy subclassing of non-Moose classes
9 #Summary(pl.UTF-8):     
10 Name:           perl-MooseX-NonMoose
11 Version:        0.22
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/MooseX/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  08627b8575835e64b44e82424df27a8f
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/MooseX-NonMoose/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-List-MoreUtils
24 BuildRequires:  perl-Moose >= 1.15
25 BuildRequires:  perl(Test::Fatal)
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 MooseX::NonMoose allows for easily subclassing non-Moose classes with
32 Moose, taking care of the annoying details connected with doing this,
33 such as setting up proper inheritance from Moose::Object and
34 installing (and inlining, at make_immutable time) a constructor that
35 makes sure things like BUILD methods are called. It tries to be as
36 non-intrusive as possible - when this module is used, inheriting from
37 non-Moose classes and inheriting from Moose classes should work
38 identically, aside from the few caveats mentioned below.
39 One of the goals of this module is that including it in a
40 Moose::Exporter-based package used across an entire application should
41 be possible, without interfering with classes that only inherit from
42 Moose modules, or even classes that don't inherit from anything at
43 all.
44
45 # %description -l pl.UTF-8
46 # TODO
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/MooseX/*.pm
71 %{perl_vendorlib}/MooseX/NonMoose
72 %{_mandir}/man3/*
This page took 0.049699 seconds and 2 git commands to generate.