]> git.pld-linux.org Git - packages/perl-Moo.git/blob - perl-Moo.spec
8dd0e7983b6c6403e8fa3791dd89f51f27d2d202
[packages/perl-Moo.git] / perl-Moo.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Moo
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Moo - Minimalist Object Orientation (with Moose compatibility)
8 Summary(pl.UTF-8):      Moo - Minimalist Object Orientation (minimalna obiektowość, zgodna z Moose)
9 Name:           perl-Moo
10 Version:        2.003004
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/H/HA/HAARG/Moo-%{version}.tar.gz
16 # Source0-md5:  d4fcd0f240033198571fcc81ce7c5f15
17 URL:            https://metacpan.org/release/Moo
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Exporter) >= 5.57
22 BuildRequires:  perl-Class-Method-Modifiers >= 2.11
23 BuildRequires:  perl-Devel-GlobalDestruction >= 0.11
24 BuildRequires:  perl-Module-Runtime >= 0.014
25 BuildRequires:  perl-Role-Tiny >= 2
26 BuildRequires:  perl-Scalar-List-Utils
27 BuildRequires:  perl-Sub-Quote >= 2.003001
28 BuildRequires:  perl-Test-Fatal >= 0.003
29 BuildRequires:  perl-Test-Simple >= 0.94
30 BuildRequires:  perl-strictures >= 2
31 %endif
32 Requires:       perl-Devel-GlobalDestruction >= 0.11
33 Requires:       perl-Module-Runtime >= 0.014
34 Requires:       perl-Role-Tiny >= 2
35 Requires:       perl-Sub-Quote >= 2.003001
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This module is an extremely light-weight subset of Moose optimised for
41 rapid startup and "pay only for what you use".
42
43 It also avoids depending on any XS modules to allow simple
44 deployments. The name Moo is based on the idea that it provides almost
45 -- but not quite -- two thirds of Moose.
46
47 Unlike Mouse this module does not aim at full compatibility with
48 Moose's surface syntax, preferring instead of provide full
49 interoperability via the metaclass inflation capabilities described in
50 documentation.
51
52 %description -l pl.UTF-8
53 Ten moduł to ekstremalnie lekki podzbiór Moose zoptymalizowany pod
54 kątem szybkiego uruchamiania i "płacenia tylko za to, czego się
55 używa".
56
57 Moduł ten unika także zależności od dowolnych modułów XS, co pozwala
58 na proste wdrożenia. Nazwa Moo opiera się na idei, że moduł ten
59 udostępnia prawie - ale nie dokładnie - dwie trzecie Moose.
60
61 W przeciwieństwie do Moose, celem modułu nie jest zapewnienie pełnej
62 zgodności ze składnią Moose, zamiast tego zapewniona jest pełna
63 interoperacyjność poprzez możliwości inflacji metaklasy, opisane w
64 dokumentacji.
65
66 %prep
67 %setup -q -n %{pdir}-%{version}
68
69 %build
70 %{__perl} Makefile.PL \
71         INSTALLDIRS=vendor
72 %{__make}
73
74 %{?with_tests:%{__make} test}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} pure_install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc Changes README
88 %dir %{perl_vendorlib}/Method
89 %dir %{perl_vendorlib}/Method/Generate
90 %{perl_vendorlib}/Method/Generate/Accessor.pm
91 %{perl_vendorlib}/Method/Generate/BuildAll.pm
92 %{perl_vendorlib}/Method/Generate/Constructor.pm
93 %{perl_vendorlib}/Method/Generate/DemolishAll.pm
94 %{perl_vendorlib}/Moo.pm
95 %{perl_vendorlib}/Moo
96 %{perl_vendorlib}/oo.pm
97 %{_mandir}/man3/Moo.3pm*
98 %{_mandir}/man3/Moo::Role.3pm*
99 %{_mandir}/man3/oo.3pm*
This page took 0.074397 seconds and 2 git commands to generate.