]> git.pld-linux.org Git - packages/perl-Moo.git/blob - perl-Moo.spec
24acb54c6ef9799158f78a13e984216ea0e846ec
[packages/perl-Moo.git] / perl-Moo.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Moo
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Moo - Minimalist Object Orientation (with Moose compatibility)
8 Summary(pl.UTF-8):      Moo - Minimalist Object Orientation (minimalna obiektowość, zgodna z Moose)
9 Name:           perl-Moo
10 Version:        2.000002
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/H/HA/HAARG/Moo-%{version}.tar.gz
16 # Source0-md5:  8b84a7289fc6247de5ec5d151105fd6b
17 URL:            http://search.cpan.org/dist/Moo/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Method-Modifiers >= 2.11
22 BuildRequires:  perl-Devel-GlobalDestruction >= 0.11
23 BuildRequires:  perl-Module-Runtime >= 0.014
24 BuildRequires:  perl-Role-Tiny >= 2
25 BuildRequires:  perl-Test-Fatal >= 0.003
26 BuildRequires:  perl-Test-Simple >= 0.94
27 BuildRequires:  perl-strictures >= 2
28 %endif
29 Requires:       perl-Devel-GlobalDestruction >= 0.11
30 Requires:       perl-Module-Runtime >= 0.014
31 Requires:       perl-Role-Tiny >= 2
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 This module is an extremely light-weight subset of Moose optimised for
37 rapid startup and "pay only for what you use".
38
39 It also avoids depending on any XS modules to allow simple
40 deployments. The name Moo is based on the idea that it provides almost
41 -- but not quite -- two thirds of Moose.
42
43 Unlike Mouse this module does not aim at full compatibility with
44 Moose's surface syntax, preferring instead of provide full
45 interoperability via the metaclass inflation capabilities described in
46 documentation.
47
48 %description -l pl.UTF-8
49 Ten moduł to ekstremalnie lekki podzbiór Moose zoptymalizowany pod
50 kątem szybkiego uruchamiania i "płacenia tylko za to, czego się
51 używa".
52
53 Moduł ten unika także zależności od dowolnych modułów XS, co pozwala
54 na proste wdrożenia. Nazwa Moo opiera się na idei, że moduł ten
55 udostępnia prawie - ale nie dokładnie - dwie trzecie Moose.
56
57 W przeciwieństwie do Moose, celem modułu nie jest zapewnienie pełnej
58 zgodności ze składnią Moose, zamiast tego zapewniona jest pełna
59 interoperacyjność poprzez możliwości inflacji metaklasy, opisane w
60 dokumentacji.
61
62 %prep
63 %setup -q -n %{pdir}-%{version}
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor
68 %{__make}
69
70 %{?with_tests:%{__make} test}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} pure_install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes README
84 %dir %{perl_vendorlib}/Method
85 %dir %{perl_vendorlib}/Method/Generate
86 %{perl_vendorlib}/Method/Generate/Accessor.pm
87 %{perl_vendorlib}/Method/Generate/BuildAll.pm
88 %{perl_vendorlib}/Method/Generate/Constructor.pm
89 %{perl_vendorlib}/Method/Generate/DemolishAll.pm
90 %{perl_vendorlib}/Method/Inliner.pm
91 %{perl_vendorlib}/Moo.pm
92 %{perl_vendorlib}/Moo
93 %{perl_vendorlib}/Sub/Defer.pm
94 %{perl_vendorlib}/Sub/Quote.pm
95 %{perl_vendorlib}/oo.pm
96 %{_mandir}/man3/Moo.3pm*
97 %{_mandir}/man3/Moo::Role.3pm*
98 %{_mandir}/man3/Sub::Defer.3pm*
99 %{_mandir}/man3/Sub::Quote.3pm*
100 %{_mandir}/man3/oo.3pm*
This page took 0.087784 seconds and 2 git commands to generate.