]> git.pld-linux.org Git - packages/perl-Module-Util.git/blob - perl-Module-Util.spec
e17fd43ea755c08083df9eda711894045e7a301f
[packages/perl-Module-Util.git] / perl-Module-Util.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Module
6 %define         pnam    Util
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Module::Util - Module name tools and transformations
9 Name:           perl-Module-Util
10 Version:        1.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d9e5d48b7f1aee18582fab57f27cccfa
17 URL:            http://search.cpan.org/dist/Module-Util/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module provides a few useful functions for manipulating module
26 names. Its main aim is to centralise some of the functions commonly
27 used by modules that manipulate other modules in some way, like
28 converting module names to relative paths.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Build.PL \
35         destdir=$RPM_BUILD_ROOT \
36         installdirs=vendor
37 ./Build
38
39 %{?with_tests:./Build test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 ./Build install
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes README
52 %{perl_vendorlib}/Module/*.pm
53 %attr(755,root,root) %{_bindir}/pm_which
54 %{_mandir}/man1/pm_which.1p*
55 %{_mandir}/man3/*
This page took 0.06684 seconds and 2 git commands to generate.