]> git.pld-linux.org Git - packages/perl-Module-Runtime-Conflicts.git/blob - perl-Module-Runtime-Conflicts.spec
try to fix install to buildroot
[packages/perl-Module-Runtime-Conflicts.git] / perl-Module-Runtime-Conflicts.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Runtime-Conflicts
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Module::Runtime::Conflicts - Provide information on conflicts for Module::Runtime
9 Name:           perl-Module-Runtime-Conflicts
10 Version:        0.001
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  310e525981ac1338f247626b8ce53dff
17 URL:            http://search.cpan.org/dist/Module-Runtime-Conflicts/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Module::Build::Tiny)
23 BuildRequires:  perl-Dist-CheckConflicts
24 BuildRequires:  perl-Module-Runtime
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module provides conflicts checking for Module::Runtime, which had
31 a recent release that broke some versions of Moose. It is called from
32 Moose::Conflicts and moose-outdated.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Build.PL \
39         perl=%{__perl} \
40         installdirs=vendor
41 ./Build
42 %{?with_tests:./Build test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 ./Build install \
47         destdir=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes INSTALL README
55 %{perl_vendorlib}/Module/Runtime
56 %{_mandir}/man3/*
This page took 0.064182 seconds and 4 git commands to generate.