]> git.pld-linux.org Git - packages/perl-Module-Info.git/blob - perl-Module-Info.spec
- macros version to ensure perl macros are loaded
[packages/perl-Module-Info.git] / perl-Module-Info.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Module
6 %define         pnam    Info
7 Summary:        Module::Info perl module - information about Perl modules
8 Summary(pl.UTF-8):      Moduł perla Module::Info - informacje o modułach Perla
9 Name:           perl-Module-Info
10 Version:        0.37
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  72dd1a99bc124a97888cbbedc37993ca
17 URL:            https://metacpan.org/release/Module-Info
18 %if %{with tests}
19 BuildRequires:  perl(File::Spec) >= 0.8
20 BuildRequires:  perl-B-Utils >= 0.27
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Module::Info gives you information about Perl modules without actually
30 loading the module. It actually isn't specific to modules and should
31 work on any perl code.
32
33 %description -l pl.UTF-8
34 Module::Info podaje informacje o modułach Perla bez wczytywania
35 modułu. Działanie to właściwie nie jest ograniczone do modułów i
36 powinno działać z dowolnym kodem w Perlu.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %attr(755,root,root) %{_bindir}/module_info
61 %attr(755,root,root) %{_bindir}/pfunc
62 %{perl_vendorlib}/B/Module
63 %{perl_vendorlib}/Module/Info.pm
64 %{_mandir}/man1/module_info.1p*
65 %{_mandir}/man1/pfunc.1p*
66 %{_mandir}/man3/B::Module::Info.3pm*
67 %{_mandir}/man3/Module::Info.3pm*
This page took 0.077205 seconds and 3 git commands to generate.