]> git.pld-linux.org Git - packages/perl-Module-Info.git/blob - perl-Module-Info.spec
3d6719dbad42b02447a1fac1f4ec47b76c5d55b8
[packages/perl-Module-Info.git] / perl-Module-Info.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Info
7 Summary:        Module::Info perl module - information about Perl modules
8 Summary(pl.UTF-8):      Moduł perla Module::Info - informacje o modułach Perla
9 Name:           perl-Module-Info
10 Version:        0.37
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  72dd1a99bc124a97888cbbedc37993ca
17 URL:            http://search.cpan.org/dist/Module-Info/
18 %if %{with tests}
19 BuildRequires:  perl(B::Utils) >= 0.27
20 BuildRequires:  perl(File::Spec) >= 0.8
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Module::Info gives you information about Perl modules without actually
29 loading the module. It actually isn't specific to modules and should
30 work on any perl code.
31
32 %description -l pl.UTF-8
33 Module::Info podaje informacje o modułach Perla bez wczytywania
34 modułu. Działanie to właściwie nie jest ograniczone do modułów i
35 powinno działać z dowolnym kodem w Perlu.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %attr(755,root,root) %{_bindir}/module_info
60 %attr(755,root,root) %{_bindir}/pfunc
61 %{perl_vendorlib}/B/Module
62 %{perl_vendorlib}/Module/Info.pm
63 %{_mandir}/man1/module_info.1p*
64 %{_mandir}/man1/pfunc.1p*
65 %{_mandir}/man3/B::Module::Info.3pm*
66 %{_mandir}/man3/Module::Info.3pm*
This page took 0.072081 seconds and 2 git commands to generate.