]> git.pld-linux.org Git - packages/perl-Module-Build.git/blob - perl-Module-Build.spec
34debe39aa9234f3e1db24ef719538eb0aa228ac
[packages/perl-Module-Build.git] / perl-Module-Build.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "./Build test"
4 #
5 %define         pdir    Module
6 %define         pnam    Build
7 Summary:        Module::Build - build and install Perl modules
8 Summary(pl.UTF-8):      Module::Build - budowanie i instalowanie modułów Perla
9 Name:           perl-Module-Build
10 Version:        0.4229
11 Release:        1
12 Epoch:          2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  1447d9e02e63f7a1643986789a8f1ba9
18 Patch0:         %{name}-startperl.patch
19 URL:            http://search.cpan.org/dist/Module-Build/
20 BuildRequires:  perl(File::Spec) >= 0.82
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-CPAN-Meta >= 2.142060
25 BuildRequires:  perl-CPAN-Meta-YAML >= 0.003
26 BuildRequires:  perl-ExtUtils-CBuilder >= 0.27
27 BuildRequires:  perl-ExtUtils-ParseXS >= 2.21
28 BuildRequires:  perl-File-Temp >= 0.15
29 BuildRequires:  perl-Module-Metadata >= 1.000002
30 BuildRequires:  perl-Parse-CPAN-Meta >= 1.4401
31 BuildRequires:  perl-Perl-OSType >= 1.00
32 BuildRequires:  perl-Test-Harness >= 3.16
33 BuildRequires:  perl-Test-Simple >= 0.49
34 BuildRequires:  perl-YAML > 0.49_01
35 BuildRequires:  perl-version >= 1:0.87
36 %endif
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Module::Build is a Perl module to build and install Perl modules. It
42 is meant to be a replacement for ExtUtils::MakeMaker.
43
44 %description -l pl.UTF-8
45 Module::Build to moduł Perla do budowania i instalowania modułów
46 Perla. Ma być zamiennikiem ExtUtils::MakeMaker.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50 %patch0 -p1
51
52 %build
53 %{__perl} Build.PL \
54         installdirs=vendor \
55         destdir=$RPM_BUILD_ROOT
56 ./Build
57
58 %{?with_tests:./Build test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 ./Build install
64
65 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Module/Build/*.pod
66 for s in Default MacOS VMS VOS Windows aix cygwin darwin os2 ; do
67         %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Module/Build/Platform/${s}.pm
68         %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/Module::Build::Platform::${s}.3pm
69 done
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes
77 %attr(755,root,root) %{_bindir}/config_data
78 %{perl_vendorlib}/Module/Build.pm
79 %dir %{perl_vendorlib}/Module/Build
80 %{perl_vendorlib}/Module/Build/*.pm
81 %dir %{perl_vendorlib}/Module/Build/Platform
82 %{perl_vendorlib}/Module/Build/Platform/Unix.pm
83 %{_mandir}/man1/config_data.1*
84 %{_mandir}/man3/Module::Build.3pm*
85 %{_mandir}/man3/Module::Build::[!P]*.3pm*
86 %{_mandir}/man3/Module::Build::PPMMaker.3pm*
87 %{_mandir}/man3/Module::Build::Platform::Unix.3pm*
This page took 0.043076 seconds and 2 git commands to generate.