]> git.pld-linux.org Git - packages/perl-Module-Build-Deprecated.git/blob - perl-Module-Build-Deprecated.spec
- new
[packages/perl-Module-Build-Deprecated.git] / perl-Module-Build-Deprecated.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    Build-Deprecated
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Module::Build::Deprecated - A collection of modules removed from Module-Build
9 Summary(pl.UTF-8):      Module::Build::Deprecated - zbiór modułów usuniętych z Module-Build
10 Name:           perl-Module-Build-Deprecated
11 Version:        0.4210
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  0e6e5f4f27f0ea6990f29f6e10aa65e6
18 URL:            http://search.cpan.org/dist/Module-Build-Deprecated/
19 BuildRequires:  perl-Module-Build >= 0.3601
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-CPAN-Meta-YAML >= 0.002
24 BuildRequires:  perl-Module-Metadata
25 BuildRequires:  perl-Test-Simple
26 BuildRequires:  perl-version >= 0.87
27 %endif
28 Requires:       perl-Module-Build >= 0.4210
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module contains a number of module that have been removed from
34 Module-Build: ModuleInfo, Version and YAML.
35
36 %description -l pl.UTF-8
37 Ten moduł zawiera zbiór modułów, które zostały usunięte z dystrybucji
38 Module-Build: ModuleInfo, Version oraz YAML.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Build.PL \
45         destdir=$RPM_BUILD_ROOT \
46         installdirs=vendor
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 ./Build install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Module/Build/Deprecated.pm
63 %{perl_vendorlib}/Module/Build/ModuleInfo.pm
64 %{perl_vendorlib}/Module/Build/Version.pm
65 %{perl_vendorlib}/Module/Build/YAML.pm
66 %{_mandir}/man3/Module::Build::Deprecated.3pm*
67 %{_mandir}/man3/Module::Build::ModuleInfo.3pm*
68 %{_mandir}/man3/Module::Build::Version.3pm*
69 %{_mandir}/man3/Module::Build::YAML.3pm*
This page took 0.071423 seconds and 3 git commands to generate.