]> git.pld-linux.org Git - packages/perl-Mixin-Linewise.git/blob - perl-Mixin-Linewise.spec
ca95274a1d25ac25f5e2951aa612fe5a59c0c3ed
[packages/perl-Mixin-Linewise.git] / perl-Mixin-Linewise.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Mixin
6 %define         pnam    Linewise
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Mixin::Linewise - write your linewise code for handles; this does the rest
9 #Summary(pl.UTF-8):     
10 Name:           perl-Mixin-Linewise
11 Version:        0.106
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/Mixin-Linewise-0.106.tar.gz
17 # Source0-md5:  d4699cde97d8286f44624c1d19663334
18 URL:            http://search.cpan.org/dist/Mixin-Linewise/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(PerlIO::utf8_strict)
23 BuildRequires:  perl-Sub-Exporter
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 It's boring to deal with opening files for IO, converting strings to
30 handle-like objects, and all that.  With Mixin::Linewise::Readers and
31 Mixin::Linewise::Writers, you can just write a method to handle
32 handles, and methods for handling strings and filenames are added for
33 you.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %dir %{perl_vendorlib}/Mixin
58 %{perl_vendorlib}/Mixin/*.pm
59 %{perl_vendorlib}/Mixin/Linewise
60 %{_mandir}/man3/*
This page took 0.052305 seconds and 2 git commands to generate.