]> git.pld-linux.org Git - packages/perl-Math-expr_eval.git/blob - perl-Math-expr_eval.spec
use generic url
[packages/perl-Math-expr_eval.git] / perl-Math-expr_eval.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    expr_eval
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Math::expr_eval - an expression evaluator
9 Summary(pl.UTF-8):      Math::expr_eval - obliczanie wyrażeń
10 %define _ver    %(echo %{version} | tr . _)
11 Name:           perl-Math-expr_eval
12 Version:        1.0
13 Release:        2
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}_%{_ver}.zip
18 # Source0-md5:  f4962039a99c1dddf460291b1cf5feff
19 URL:            http://search.cpan.org/dist/Math-expr_eval/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  unzip
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is an expression evaluator. It has three main objectives:
28 efficiency, extensibility, user-friendly error messages. It's features
29 include: standard data types, arithmetic and boolean operators,
30 conditionals, pattern matching, user-defined data types, user-defined
31 binary operators and prefix unary operators, over-loaded binary
32 operators and prefix unary operators, calls to user-provided perl
33 functions, a mode for syntax checking only, optimized re-evaluation of
34 expressions, multiple symbol tables.
35
36 %description -l pl.UTF-8
37 Ten moduł służy do obliczania wyrażeń. Ma trzy główne cele: wydajność,
38 rozszerzalność i przyjazne dla użytkownika komunikaty błędów. Jego
39 możliwości obejmują: standardowe typy danych, operatory arytmetyczne i
40 logiczne, warunki, dopasowywanie wzorców, definiowalne typy danych,
41 definiowalne operatory dwuargumentowe i prefiksowe jednoargumentowe,
42 przeciążone operatory dwuargumentowe i prefiksowe jednoargumentowe,
43 wywołania dostarczonych funkcji Perla, tryb do sprawdzania składni,
44 zoptymalizowane ponowne obliczanie wyrażeń, wiele tablic symboli.
45
46 %prep
47 %setup -q -c
48
49 mv -f Makefile.pl Makefile.PL
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/Math/expr_eval.pm
This page took 0.329184 seconds and 3 git commands to generate.